[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Cheshire Cat Computing • View topic - Graphs do not update.

Cheshire Cat Computing

Software support and information
It is currently Fri Oct 30, 2020 4:58 pm

All times are UTC + 12 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Graphs do not update.
PostPosted: Thu Aug 03, 2006 11:38 am 
Offline
User

Joined: Thu Aug 03, 2006 10:53 am
Posts: 3
Location: Racine County, Wisconsin USA
I am running (new install) the latest MRTG - RRD - and routers2.

Generating the *.cfg without the RRD lines runs standard MRTG and the graphs all update as expected. I have done this several times to ensure that snmp is running correctly and that new data is being acquired.

Adding the RRD lines to the *.cfg file does perform the expected conversions to RRD format. However, the only data displayed in the graphs is from when they were MRTG - nothing new. I have changed the withpeak and maxima options to every possible combination. I have set the IIS 6.0 to not cache my /graphs folder.

All of the values for In Out Min Max etc are displaying -1.#J

http://www.mobileps.com/cgi-bin/routers2.pl?page=verify seems to indicate everything is OK.

Any assistance will be gratly appreciated.


Top
 Profile Send private message  
 
 Post subject:
PostPosted: Thu Aug 03, 2006 5:46 pm 
Offline
Site Admin

Joined: Tue Jul 29, 2003 11:42 am
Posts: 3039
Location: Auckland, New Zealand
Check that you really are running MRTG every 5 mins on the .cfg files - remember you still need to do this to collect the data.

When MRTG runs, does it produce any error messages? Maybe this would help.

If you've just converted to rrdtool, does the user that MRTG runs as have write permission to the newly converted .rrd files?

routers2 seems to be running correctly, but your MRTG data-gathering is not. Check the error message output from the MRTG process.

_________________
Steve Shipway
UNIX Systems, ITSS, University of Auckland, NZ
Woe unto them that rise up early in the morning... -- Isaiah 5:11


Top
 Profile Send private message  
 
 Post subject:
PostPosted: Fri Aug 04, 2006 6:42 am 
Offline
User

Joined: Thu Aug 03, 2006 10:53 am
Posts: 3
Location: Racine County, Wisconsin USA
Well, that was bizzare.

1. I went back and changed all of the .cfg files to REMOVE the 3 lines for rrd tool.
2. I let "regular" MRTG run for 2 hours to ensure that data collection was occurring.
3. I DELETED all of my rrd files.
4. I DELETED all of my existing graphs.
5. I changed all of the .cfg files to once again contain the 3 lines for rrd tool.
6. All rrd files were properly re-created.
7. All graphs are now working correctly.

There must have been sometype of file lock in there somewhere. Anyway - all is well now. THANKS.


Top
 Profile Send private message  
 
 Post subject:
PostPosted: Mon Aug 07, 2006 11:49 am 
Offline
Site Admin

Joined: Tue Jul 29, 2003 11:42 am
Posts: 3039
Location: Auckland, New Zealand
Once I had this problem, and it turned out that the .rrd files were owned by root but the gathering process was owned by mrtg. This is because my first data run was done manually (as root) but subsequent ones ran as the correct mrtg user. Hence the files were read-only. Maybe this was the problem?

_________________
Steve Shipway
UNIX Systems, ITSS, University of Auckland, NZ
Woe unto them that rise up early in the morning... -- Isaiah 5:11


Top
 Profile Send private message  
 
 Post subject:
PostPosted: Tue Aug 08, 2006 2:29 am 
Offline
User

Joined: Thu Aug 03, 2006 10:53 am
Posts: 3
Location: Racine County, Wisconsin USA
I suspect that the Windows equivilent was the problem.

I have written a Windows Service to read an xml file, run the cfgmaker, modify the .cfg files to utilize rrd, and perform data collection at specific intervals.

It turns out that when logged on to the system with Admin permissions everything was executing fine during development. Once I launched the service with local system rights, it was unable to update the rrd files. It did however update the mrtg html files.

If I get some spare time I plan to look into this a little deeper.

Thanks for all of your help.


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 12 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 50 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group