[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4688: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4690: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4691: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Cheshire Cat Computing • View topic - Perl 5.10 and RRDtool

Cheshire Cat Computing

Software support and information
It is currently Mon Oct 21, 2019 4:17 am

All times are UTC + 12 hours [ DST ]




Post new topic Reply to topic  [ 52 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Perl 5.10 and RRDtool
PostPosted: Tue Dec 09, 2008 5:35 pm 
Offline
Site Admin

Joined: Tue Jul 29, 2003 11:42 am
Posts: 3039
Location: Auckland, New Zealand
There have been a couple of people reporting problems running RRDtool 1.2.x modules with Perl 5.10.

If you get Perl crashes (half-completed pages etc) then you may be affected. Check your apache logs to see errors about 'unable to free scalar' or similar.

So far, recommended actions are:

1) Reinstall RRDTool and the RRD Perl modules from source, if you installed from an RPM. Most RPMs are built for Perl 5.8 and this may be a cause.
2) Upgrade to RRDtool 1.3.4 (or whatever is most recent) as the 1.3 branch may not have this problem.

Please report your system config (run 'perl -V' and post the details here) if you're being affected by this.

_________________
Steve Shipway
UNIX Systems, ITSS, University of Auckland, NZ
Woe unto them that rise up early in the morning... -- Isaiah 5:11


Top
 Profile Send private message  
 
PostPosted: Wed Nov 25, 2009 7:19 am 
Offline
Contributor

Joined: Thu Dec 29, 2005 1:09 pm
Posts: 58


Top
 Profile Send private message  
 
PostPosted: Wed Nov 25, 2009 9:38 am 
Offline
Site Admin

Joined: Tue Jul 29, 2003 11:42 am
Posts: 3039
Location: Auckland, New Zealand
Are you getting any error messages in your web server error logs? That would be the apache logs/error_log file I think for you. This would give indications of any perl errors. Also, if you are using mod_perl or speedycgi then disable them temporarily and try again - sometimes they can hide error messages or can even introduce new errors.
Let me know if theres anything in the error logs.

_________________
Steve Shipway
UNIX Systems, ITSS, University of Auckland, NZ
Woe unto them that rise up early in the morning... -- Isaiah 5:11


Top
 Profile Send private message  
 
PostPosted: Wed Nov 25, 2009 11:01 am 
Offline
Contributor

Joined: Thu Dec 29, 2005 1:09 pm
Posts: 58
Thanks for looking into this.

No errors in the apache2 error logs.

I am using speedycgi so I disabled it (first line of routers2.cgi and change of cache statement in conf) but other than it running a lot slower there's no change in output and no change in the log files.

I noticed in the verify page that it says "RRDs library found OK (Version 1.3.1)" but I'm running RRDtool 1.4.2... is this OK? Should I expect the library version to be different from the binary?


Top
 Profile Send private message  
 
PostPosted: Wed Nov 25, 2009 7:00 pm 
Offline
Site Admin

Joined: Tue Jul 29, 2003 11:42 am
Posts: 3039
Location: Auckland, New Zealand

_________________
Steve Shipway
UNIX Systems, ITSS, University of Auckland, NZ
Woe unto them that rise up early in the morning... -- Isaiah 5:11


Top
 Profile Send private message  
 
PostPosted: Thu Nov 26, 2009 3:53 am 
Offline
Contributor

Joined: Thu Dec 29, 2005 1:09 pm
Posts: 58
I found RRDs.pm and other RRD related perl stuff in other spots and blew it away. Then reinstalled rrdtool 1.4.2. I then had to put a libadd statement in routers2.conf and now verify is reporting "RRDs library found OK (Version 1.4.2)". Thanks for your help with this!

However, the initial problem of graphs not showing up when using 6-hour view still exists. I've touched the cgi, cleared cache, etc. to no avail. :(


Top
 Profile Send private message  
 
PostPosted: Thu Nov 26, 2009 10:48 am 
Offline
Site Admin

Joined: Tue Jul 29, 2003 11:42 am
Posts: 3039
Location: Auckland, New Zealand
So, as I understand it, when using Perl 5.10 and Routers2 2.20, if you are looking at the Summary page for 6-hour with the 'active' option set, you get no graphs displayed (as if all interfaces were inactive).

Can you give a definite confirm that the RRD files for these graphs have a 60-sec interval? If they are 5-min interval, then attempting to do a 6-hour summary may extract unusual data and give routers2 the impression that they are zero... thugh this shouldnt happen.

I'll check the isactive() function code for behaviour in 6-hour mode.

_________________
Steve Shipway
UNIX Systems, ITSS, University of Auckland, NZ
Woe unto them that rise up early in the morning... -- Isaiah 5:11


Top
 Profile Send private message  
 
PostPosted: Thu Nov 26, 2009 11:20 am 
Offline
Contributor

Joined: Thu Dec 29, 2005 1:09 pm
Posts: 58
You've got it correct. I've also confirmed that they are 1-minute interval graphs. Also, this worked perfectly until the Ububntu upgrade I just did which included 1000's of package updates.

Routers2 2.20
Perl 5.10.0
RRDtool 1.4.2
/etc/issue: Ubuntu 9.04 \n \l
uname -a: Linux jii-btn1 2.6.28-16-server #55-Ubuntu SMP Tue Oct 20 20:50:00 UTC 2009 i686 GNU/Linux


Top
 Profile Send private message  
 
PostPosted: Thu Jan 05, 2012 3:26 am 
Offline
User

Joined: Thu Jan 05, 2012 3:21 am
Posts: 1
Just wanted to say that i had problems running RRDtool 1.2.x modules with Perl 5.10 too.
After reinstalling RRDTool and the RRD Perl modules from source it seems to have stopped crashing. Will give an update if anything crops up. Thanks


Top
 Profile Send private message  
 
PostPosted: Tue Feb 21, 2012 5:08 am 
Offline
User

Joined: Tue Feb 21, 2012 5:04 am
Posts: 1
What a great tool the internet is! I was having the same issue and found this post! Great work Steve you stopped me pulling my hair out :)


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 52 posts ]  Go to page 1, 2, 3, 4, 5, 6  Next

All times are UTC + 12 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group